Home » Categories » Multiple Categories

Stuck on ArmA3 loading screen

If you hit "Play" on the launcher and get stuck on the ArmA3 loading screen... here‘s how to fix it.

First go to steam and verify the integrity of your ArmA3 (Right click, go to preferences, Local files, Verify). Once it has checked it will most likely say that 2 files need to be re-acquired... let it do that then verify again.

Once that is done, launch ArmA3 from steam and join a random server (any one that you can get in to will do) move about for a couple of seconds and then exit ArmA3 through the menu system.

Load the CL3 Launcher and go to the settings tab, change your malloc to "System" and wait for it to re-highlight, then change it back to the TBB4 Malloc.

Then hit the play button.

Article Rating (3 Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
 
Attachments Attachments
There are no attachments for this article.
Comments Comments
There are no comments for this article. Be the first to post a comment.
Related Articles RSS Feed
Where can I find my ArmA Player ID?
Viewed 3769 times since Wed, Mar 9, 2016
Launcher says "TeamSpeak switch is not open"
Viewed 135 times since Thu, Apr 20, 2017
I keep getting the "Battleye failed to update" error when connecting. How do I fix this?
Viewed 340 times since Wed, Mar 9, 2016
I keep getting kicked from ts3 for (Fix your name: ***)
Viewed 256 times since Wed, Mar 9, 2016
How to install
Viewed 455 times since Mon, Apr 3, 2017
How do houses work?
Viewed 294 times since Wed, Mar 9, 2016
How to fix the "cant see the whole launcher" issue.
Viewed 540 times since Wed, Mar 9, 2016
How large size wise are all the necessary mod files? I’m bandwidth capped and just curious.
Viewed 480 times since Wed, Mar 9, 2016
A voice’s telling me that I need to be on Teamspeak when I’m trying to start City Life in the CL Launcher.
Viewed 311 times since Wed, Mar 9, 2016
BattlEye kicked for High Ping.
Viewed 633 times since Wed, Mar 9, 2016