Home » Categories » Multiple Categories

Stuck on ArmA3 loading screen

If you hit "Play" on the launcher and get stuck on the ArmA3 loading screen... here‘s how to fix it.

First go to steam and verify the integrity of your ArmA3 (Right click, go to preferences, Local files, Verify). Once it has checked it will most likely say that 2 files need to be re-acquired... let it do that then verify again.

Once that is done, launch ArmA3 from steam and join a random server (any one that you can get in to will do) move about for a couple of seconds and then exit ArmA3 through the menu system.

Load the CL3 Launcher and go to the settings tab, change your malloc to "System" and wait for it to re-highlight, then change it back to the TBB4 Malloc.

Then hit the play button.

Article Rating (4 Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
 
Attachments Attachments
There are no attachments for this article.
Comments Comments
There are no comments for this article. Be the first to post a comment.
Related Articles RSS Feed
BattlEye Error: You were banned from the server!
Viewed 914 times since Wed, Mar 9, 2016
How to install
Viewed 2105 times since Mon, Apr 3, 2017
Why can’t I access on the forum or use the launcher? I have registered.
Viewed 957 times since Wed, Mar 9, 2016
When ever I load City Life it takes ages to receive data and then it crashes, then I try to download battleye and it says it can’t find the directory.
Viewed 1375 times since Wed, Mar 9, 2016
Changing name on forum
Viewed 407 times since Thu, Oct 5, 2017
How do I get a EMT/PD ride along?
Viewed 497 times since Wed, Mar 9, 2016
How do I find my RPT file?
Viewed 834 times since Wed, Mar 9, 2016
I keep getting kicked from ts3 for (Fix your name: ***)
Viewed 885 times since Wed, Mar 9, 2016
Can I upgrade my vehicles as in logos, engines, seats, and aftermarket parts?
Viewed 1022 times since Wed, Mar 9, 2016